Bug #4738

[SDKs] Keep write error (wanted 2 but wrote 0)

Added by Bryan Cosca over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
SDKs
Target version:
-
Start date:
12/08/2014
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

A job: qr1hi-8i9sb-ea3e1vxwouqqyd4 ran with arvados-python-client==0.1.20141203161041.0cc93f8 and I received this error:

2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr Traceback (most recent call last):
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/tmp/crunch-src/crunch_scripts/crunchutil/robust_put.py", line 37, in upload
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr out.write_directory_tree(source_dir, max_manifest_depth=0)
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/commands/put.py", line 323, in write_directory_tree
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr path, stream_name, max_manifest_depth)
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 434, in write_directory_tree
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr self.do_queued_work()
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 362, in do_queued_work
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr self._work_file()
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 375, in _work_file
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr self.write(buf)
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 680, in write
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr return super(ResumableCollectionWriter, self).write(data)
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 445, in write
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr self.flush_data()
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/commands/put.py", line 299, in flush_data
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr super(ArvPutCollectionWriter, self).flush_data()
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/collection.py", line 480, in flush_data
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr self._my_keep().put(data_buffer[0:self.KEEP_BLOCK_SIZE]))
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/retry.py", line 157, in num_retries_setter
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr return orig_func(self, *args, **kwargs)
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr File "/usr/local/lib/python2.7/dist-packages/arvados/keep.py", line 719, in put
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr (data_hash, copies, thread_limiter.done()))
2014-12-08_15:35:23 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 4 stderr KeepWriteError: Write fail for 1021aa424ca54f14ff9f73683766ec98: wanted 2 but wrote 0

I've updated my python sdk and I did not encounter it again, I just wanted to let you guys know.


Related issues

Related to Arvados - Bug #3835: [SDKs] Python and CLI tools should give more helpful error messages after a Keep failureResolved01/13/2015

Is duplicate of Arvados - Bug #4736: Timeout value connect must be an int or floatResolved12/08/2014

History

#1 Updated by Brett Smith over 5 years ago

  • Subject changed from Keep write error (wanted 2 but wrote 0) to [SDKs] Keep write error (wanted 2 but wrote 0)
  • Category set to SDKs
  • Target version set to Bug Triage

#2 Updated by Brett Smith over 5 years ago

  • Status changed from New to Closed
  • Target version deleted (Bug Triage)

Earlier errors in the logs show that this job ran with a too-old version of the requests library:

2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr Exception in thread Thread-34:
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr Traceback (most recent call last):
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     self.run()
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/arvados/keep.py", line 369, in run
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     self.run_with_limiter(limiter)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/arvados/keep.py", line 381, in run_with_limiter
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     timeout=self.args.get('timeout', None)))
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/arvados/keep.py", line 337, in put
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     timeout=timeout)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/api.py", line 99, in put
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     return request('put', url, data=data, **kwargs)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/api.py", line 44, in request
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     return session.request(method=method, url=url, **kwargs)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/sessions.py", line 456, in request
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     resp = self.send(prep, **send_kwargs)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/sessions.py", line 559, in send
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     r = adapter.send(request, **kwargs)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/adapters.py", line 313, in send
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     timeout = TimeoutSauce(connect=timeout, read=timeout)
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/packages/urllib3/util/timeout.py", line 88, in __init__
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     self._connect = self._validate_timeout(connect, 'connect')
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr   File "/usr/local/lib/python2.7/dist-packages/requests-2.3.0-py2.7.egg/requests/packages/urllib3/util/timeout.py", line 119, in _validate_timeout
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr     "int or float." % (name, value))
2014-12-08_15:37:18 qr1hi-8i9sb-zil9f8j0ifz9j97 27192 1 stderr ValueError: Timeout value connect was (2, 300), but it must be an int or float.

This is a duplicate of #4736.

Also available in: Atom PDF