Bug #4756

[API] Add migration to change collection uuids to portable_data_hash in old job script_parameters

Added by Tim Pierce over 2 years ago. Updated about 1 month ago.

Status:RejectedStart date:12/09/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:API
Target version:Deferred
Story points2.0
Velocity based estimate-

Description

Following #3036 and #4269, collection uuids are forbidden from job script parameters. We have some unknown number of jobs in the database which reference input collections by uuid, and should add a migration to keep them consistent with new jobs.

The migration for this change will need to be careful to use the correct portable_data_hash for a collection as it existed at the time the job was created.

  • If the collection has not been modified since the job was recorded, then it should be safe to use the current portable_data_hash (this should cover most cases).
  • If, however, the collection has been modified more recently than the job, it will be necessary to process the logs for that collection to ensure that we use the portable_data_hash that was in effect at the time the job was processed.

Related issues

Related to Arvados - Story #3036: [API] Use regular uuids instead of content hashes to iden... Resolved 08/07/2014
Related to Arvados - Bug #4269: [API] Disallow collection UUIDs in script_parameters, onl... Resolved 12/04/2014

History

#1 Updated by Brett Smith over 2 years ago

  • Target version deleted (Bug Triage)

Per discussion in sprint retrospective, not a bug. Moving to backlog for Tom's prioritization into a future sprint.

#2 Updated by Tom Clegg over 2 years ago

  • Target version set to Deferred

#3 Updated by Tom Clegg about 1 month ago

  • Status changed from New to Rejected

Also available in: Atom PDF