Bug #4885

keep write error (wanted 2 but wrote 0) arvados

Added by neelam yadav over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Immediate
Assigned To:
Category:
-
Target version:
-
Start date:
12/30/2014
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

After reading same issue, i updated my python SDK to latest version v0.1.20141216163701.7b26b99. But still getting same error.

File "/usr/local/bin/arv-put", line 4, in <module>
import('pkg_resources').run_script('arvados-python-client==0.1.20141216163701.7b26b99', 'arv-put')
File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 517, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "/usr/local/lib/python2.7/dist-packages/pkg_resources.py", line 1436, in run_script
exec(code, namespace, namespace)
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/EGG-INFO/scripts/arv-put", line 4, in <module>
main()
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/commands/put.py", line 451, in main
writer.finish_current_stream()
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/collection.py", line 534, in finish_current_stream
self.flush_data()
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/commands/put.py", line 299, in flush_data
super(ArvPutCollectionWriter, self).flush_data()
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/collection.py", line 480, in flush_data
self._my_keep().put(data_buffer[0:self.KEEP_BLOCK_SIZE]))
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/retry.py", line 157, in num_retries_setter
return orig_func(self, *args, **kwargs)
File "/usr/local/lib/python2.7/dist-packages/arvados_python_client-0.1.20141216163701.7b26b99-py2.7.egg/arvados/keep.py", line 719, in put
(data_hash, copies, thread_limiter.done()))
arvados.errors.KeepWriteError: Write fail for c2251981055c321c8449d1ab6ff14a3d: wanted 2 but wrote 0

Related issues

Is duplicate of Arvados - Bug #3835: [SDKs] Python and CLI tools should give more helpful error messages after a Keep failureResolved01/13/2015

Copied from Arvados - Bug #4884: keep write error (wanted 2 but wrote 0) arvadosResolved12/30/2014

History

#1 Updated by Tom Clegg over 5 years ago

  • Target version set to Deferred

#2 Updated by neelam yadav over 5 years ago

  • Assigned To set to neelam yadav

#3 Updated by Brett Smith over 5 years ago

  • Status changed from New to Resolved

Applied in changeset arvados|commit:952bfa87465a27f83dca7feca7d369fda4200eb5.

#4 Updated by Tom Clegg about 5 years ago

  • Target version deleted (Deferred)

Also available in: Atom PDF