Bug #4886

[Docker] Web upload stuck at "upload in progress"

Added by neelam yadav about 2 years ago. Updated 16 days ago.

Status:ClosedStart date:12/30/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Workbench
Target version:-
Story points0.5
Velocity based estimate-

Description

While uploading a file of just 12B size in collections via arvados UI, it just keeps showing "upload in progress" message, even after a whole 1 day.

Note: Arvados is intsalled on Ubuntu 14.04 LTS using command:
\curl -sSL http://get.arvados.org | bash


Related issues

Related to Arvados - Bug #4752: [Docker] Make websockets work, probably by using passenge... Resolved 04/01/2015
Related to Arvados - Bug #3432: Uploading files into docker image using keep Closed 07/31/2014

History

#1 Updated by Tom Clegg about 2 years ago

  • Subject changed from Upload not working on Arvados UI to [Docker] Web upload stuck at "upload in progress"
  • Category set to Workbench
  • Priority changed from Immediate to Normal
  • Target version set to Arvados Future Sprints

#2 Updated by neelam yadav about 2 years ago

  • Assignee set to neelam yadav

#3 Updated by Tom Clegg about 2 years ago

  • Target version changed from Arvados Future Sprints to 2015-02-18 sprint

#4 Updated by Tom Clegg about 2 years ago

  • Story points set to 0.5

#5 Updated by Tim Pierce about 2 years ago

  • Assignee changed from neelam yadav to Tim Pierce

#6 Updated by Tom Clegg about 2 years ago

Bugs to check for:
  • Workbench uploader just gets lost / hangs (instead of throwing an error) if there is no Keep proxy
  • Workbench uploader [...] if it cannot connect to the Keep proxy
  • Docker setup does not provide a Keep proxy
  • Docker setup provides a Keep proxy on https with a self-signed certificate (and this error is not received/handled correctly by the uploader)
  • Docker setup provides a Keep proxy but it is http, and Workbench is https, so Workbench uploader is not allowed to connect to it
  • Docker setup provides an API server with a self-signed certificate, and the browser hasn't added a security exception during this session, so Workbench uploader is not allowed to connect to it

#7 Updated by Tom Clegg about 2 years ago

  • Target version changed from 2015-02-18 sprint to Arvados Future Sprints

#8 Updated by Tom Morris 4 months ago

  • Assignee changed from Tim Pierce to Tom Morris

#9 Updated by Tom Morris 16 days ago

  • Status changed from New to Closed
  • Assignee deleted (Tom Morris)
  • Target version deleted (Arvados Future Sprints)

Sorry this lingered so long, but the code base has change so much since this was reported that it'd be impossible to reproduce this.

If the problem can be recreated with the current version of the software, please reopen with additional information to reproduce the problem.

Also available in: Atom PDF