Feature #4905

[Workbench] Make repository-sharing feature accessible from Manage Account page

Added by Bryan Cosca over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Workbench
Target version:
-
Start date:
01/06/2015
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

The scenario where Bryan wants to see some of Sally's example crunch scripts that she wrote and its currently in her git repository. There should be an easier way to share these scripts.

There could be another scenario where Sally only wants to share 5 scripts out of her 20 so she doesn't want to share her whole repo. Could there be a way to only share a certain portion of her repo, maybe only a branch?


Related issues

Is duplicate of Arvados - Feature #3686: [Workbench] Provide a sharing tab for repositories similar to setting up sharing for projects.Resolved01/15/2015

Has duplicate Arvados - Feature #5022: [Workbench] User can navigate to git repository page in order to access repository sharingClosed

History

#1 Updated by Peter Amstutz over 5 years ago

  1. We can probably use the most of the existing UI for setting permissions on projects to set permissions on repositories.
  2. We need to add links under the "Repositories" panel of the "Manage account" which open the sharing UI for their repositories.
    1. Maybe pop up a dialog box?
  3. Unfortunately, sharing git repositories is an all-or-nothing thing. If we supported creating new git repositories, then Sally could copy the scripts into a new repository and share that.

#2 Updated by Radhika Chippada over 5 years ago

  • Status changed from New to Resolved

Applied in changeset arvados|commit:204c462041de0b063ed1169c0f600f082400815f.

#3 Updated by Tom Clegg over 5 years ago

  • Category set to Workbench
  • Status changed from Resolved to New
  • Target version set to Arvados Future Sprints
  • Story points set to 1.0

(Reopening because #3686 didn't provide a way for the user to find the sharing tab.)

#4 Updated by Tom Clegg over 5 years ago

  • Target version changed from Arvados Future Sprints to 2015-02-18 sprint

#5 Updated by Tom Clegg over 5 years ago

  • Subject changed from Sharing Git Repositories to [Workbench] Make repository-sharing feature accessible from Manage Account page
  • Story points changed from 1.0 to 0.5

#6 Updated by Tom Clegg over 5 years ago

  • Status changed from New to Closed

Link was added to Manage Account page in #3686.

#7 Updated by Tom Clegg over 5 years ago

  • Target version deleted (2015-02-18 sprint)

Also available in: Atom PDF