Bug #5211

[Documentation] Top Navbar of docs homepage not suitable for small window

Added by Nancy Ouyang almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Documentation
Target version:
Start date:
02/13/2015
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

docnavwrap.png (36.6 KB) docnavwrap.png Nancy Ouyang, 02/13/2015 06:29 PM

Subtasks

Task #5441: review 5211-improved-top-navbarResolvedWard Vandewege


Related issues

Related to Arvados - Feature #5493: [Workbench] Add "Getting Started" modal inside WorkbenchResolved03/30/2015

Associated revisions

Revision bf213b63 (diff)
Added by Ward Vandewege over 5 years ago

A series of changes to the top nav bar to make it more compact.

Refs #5211

Revision e893c4e1 (diff)
Added by Ward Vandewege over 5 years ago

Remove reference to as yet non-existant compute node setup page.

Refs #5211

Revision a7f93242
Added by Ward Vandewege over 5 years ago

Merge branch '5211-improved-top-navbar'

closes #5211

History

#1 Updated by Brett Smith almost 6 years ago

  • Subject changed from Top Navbar of docs homepage not suitable for small window to [Documentation] Top Navbar of docs homepage not suitable for small window
  • Category set to Documentation
  • Target version set to Bug Triage

#2 Updated by Nancy Ouyang almost 6 years ago

This happens in-between "super small" where it turns into a mobile-friendly page, and "big" when the top navbar is flat.

#3 Updated by Tom Clegg over 5 years ago

Debatably the problem is that there are too many top nav elements.

Suggest
  • Merge the nearly-useless "Admin Guide" content into the "Install" section
    • Call the merged section heading "Install" (drop "Guide")
    • Add the existing admin cheat sheet page to the Install section ("Setting up new users"?)
    • Update the cheat sheet so it also tells you to use Workbench → Users → Setup for adding users, VMs, and repos.
  • Rename "SDK Reference" to "SDKs"
  • Rename "API Reference" to "API"

#4 Updated by Tom Clegg over 5 years ago

  • Target version changed from Bug Triage to 2015-04-01 sprint

#5 Updated by Ward Vandewege over 5 years ago

  • Status changed from New to In Progress
  • Story points set to 0.5

#6 Updated by Ward Vandewege over 5 years ago

  • Assigned To set to Ward Vandewege

#7 Updated by Tom Clegg over 5 years ago

LGTM, but it exposes an existing bug which you should probably fix:

In #4186, ed4105d added a link to install-compute-node.html (via _config.yml) but didn't add that file. At the time it added a thin invisible link (invisible until you hover it, at least) under "install the crunch dispatcher" in the left nav, which was hard to notice because it looks like a bit of spacing between sections. Now, with bf213b6, the invisible link is noticeable as extra whitespace between "install the crunch dispatcher" and "cheat sheet" items.

Should add the install-compute-node.html.textile.liquid that was missing in #4186, or remove the reference to it in _config.yml.

Aside: yes, we're systematically checking for dead links, but apparently the dead-linked left nav item gets rendered as a link to baseurl instead of the missing page, so as far as linkchecker can tell it's perfectly good.

#8 Updated by Ward Vandewege over 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF