Bug #5349

[Workbench] Pipeline Template error: no implicit conversion of ActiveSupport::TimeWithZone into String

Added by Bryan Cosca over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Radhika Chippada
Category:
Workbench
Target version:
Start date:
03/02/2015
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Description

I clicked on re-run with latest on instance: qr1hi-d1hrv-idj2c7bhyqmhjcs. The pipeline queued for a few seconds and then the error message came up:

The components of this pipeline are in a format that Workbench does not recognize.

Error encountered: #<ActionView::Template::Error: no implicit conversion of ActiveSupport::TimeWithZone into String>

It looks like the job is running though in the active pipelines tab on dashboard. I just can't look at the instance at all because the message comes up.


Subtasks

Task #5355: Review branch: 5349-timestamp-error-for-running-pipelineResolvedTom Clegg

Associated revisions

Revision 912699d4
Added by Radhika Chippada over 5 years ago

closes #5349
Merge branch '5349-timestamp-error-for-running-pipeline'

History

#1 Updated by Bryan Cosca over 5 years ago

qr1hi-d1hrv-07ek396rvbutqjb is one instance that shows the problem, qr1hi-d1hrv-kd3498krej4o6ln is another.

#2 Updated by Bryan Cosca over 5 years ago

I can see the normal pipeline instance page now, but I cannot cancel any jobs. I can pause though.

Edit: Was on the wrong account

#3 Updated by Bryan Cosca over 5 years ago

Refreshing a running pipeline instance page reproduces this /sometimes/

#4 Updated by Peter Amstutz over 5 years ago

  • Target version set to Bug Triage

#5 Updated by Radhika Chippada over 5 years ago

  • Status changed from New to In Progress
  • Assigned To set to Radhika Chippada
  • Target version changed from Bug Triage to 2015-03-11 sprint

#6 Updated by Radhika Chippada over 5 years ago

  • This issue is happening for pipelines in Running state. It is due to a recent update to handle start_at timestamp in apps/workbench/app/views/pipeline_instances/_running_component.html.erb
apps/workbench/app/views/pipeline_instances/_running_component.html.erb

           <% if current_job[:state] == "Queued" %>
             <%# column offset 5 %>
             <div class="col-md-6">
-              <% queuetime = Time.now - Time.iso8601(current_job[:created_at]) %>
+              <% queuetime = Time.now - current_job[:created_at] %>
               Queued for <%= render_runtime(queuetime, true) %>.
               <% begin %>
  • Reverted that particular update as shown above
  • Added an explicit test to verify the time display for a pipeline in Running state
  • All pipeline instances test passed. Manual verification passed.

#7 Updated by Radhika Chippada over 5 years ago

  • Subject changed from Pipeline Template error: no implicit conversion of ActiveSupport::TimeWithZone into String to [Workbench] Pipeline Template error: no implicit conversion of ActiveSupport::TimeWithZone into String
  • Category set to Workbench

#8 Updated by Tom Clegg over 5 years ago

Added a test in 4393148 that passes with a1d70a2 but not without it. Using Time.parse(current_job[:created_at].to_s) seems to address the current bug without reinstating the older bug that (I'm assuming) motivated a1d70a2.

#9 Updated by Radhika Chippada over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:912699d40991706b279aa6f9ed51991ea9250001.

#10 Updated by Ward Vandewege over 5 years ago

  • Story points set to 0.5

Also available in: Atom PDF