Feature #5514

Workbench enhancements

Added by Abram Connelly about 4 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
03/19/2015
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Here is a list of enhancmenets and annoyances in workbench that I have:

- Show log collection at the pipeline level, job level or somewhere else featured prominently without having to go into the 'log' pane or having to dig it out of the 'API response' JSON.
For long jobs, the log file is big which means the 'log' pane takes a while to load (if ever?) so I would like to look at it through my keep mount. Find the collection UUID or portable data hash is a major pain because I have to look at the API response and dig it out.

- For a running job, the 'cancel' button looks too much like the 'failed' button.
I have to look at it twice to realize that the big red button on my running job is there in case I want to cancel the job, not because the job has failed. Either move it, make it a different color or otherwise differentiate it from the 'failed' state to alleviate confusion.

- Conflate pipeline rus with the same input.
While debugging a pipeline I am often running the same pipeline with the same input with only the docker image or the git repo version changed. These pipeline runs are logically connected in my mind. It would be nice to have them grouped instead of shown linearly one right after the other as if they were distinct pipelines.

- Allow 'starring' pipeline instances, projects and collections.
Some pipeline runs and collections I find myself using all the time. It would be nice to have a facility to easily move to the ones I've marked as being important. Pipeline instances especially as any pipeline instance that is longer than a week old is effectively lost.

- Allow different views from the dashboard into the pipelines run or collections created.
'Recently finished pipelines' isn't always the most important thing I would like to see. Most likely I would like to see my own pipeline instances run and not the global (or whatever group I'm in) pipeline runs. Better yet, it would be nice to filter by person, group or some other pattern.

- Make job graphs readable
When a job runs the graphs produced are a mass of unintellegible lines and dots with only the x-axis labelled. It would be nice to be able to filter based on node, processor, pattern, CPU, I/O or memory usage to give a clearer indication of what's going on. It is necessary to know what the y-axis is fore reference. It would be nice to have the option to dynamically resize the y-axis, keep it fixed or provide a range. For even reasonably sized jobs, displaying the running tasks will become unreadable without some facility to filter or aggregate data. It might also be interesting to provide 'signposts' to indicate when jobs complete so that you can get a rough sense for how your job is progressing.


Related issues

Is duplicate of Arvados - Task #5649: [Workbench] We need better job graphs, less spaghettiNew

Copied to Arvados - Bug #5665: [Workbench] Link to log from pipeline and/or job summary pageNew04/03/2015

Copied to Arvados - Bug #5666: [Workbench] Job "failed" label and "Cancel" button need more distinctionResolved04/03/2015

Copied to Arvados - Bug #5667: [Workbench] Indicate related pipeline instancesNew04/03/2015

Copied to Arvados - Feature #5668: [Workbench] Favorite projects, pipelines, collectionsNew11/10/2015

Copied to Arvados - Bug #5669: [Workbench] Make Dashboard contents filterableNew04/03/2015

History

#1 Updated by Brett Smith about 4 years ago

  • Status changed from New to Closed

I have created individual tickets for all these requests to aid prioritization, estimation, and planning. I'm closing this ticket in lieu of those, which are all linked.

Also available in: Atom PDF