Bug #5923

Fiddlesticks when trying to view a log file

Added by Bryan Cosca over 2 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
05/06/2015
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

https://cloud.curoverse.com/jobs/qr1hi-8i9sb-8rp82pposgfl99y#Log

I think this is because I removed a bunch of log files from the project that this was run instance was run in.


Related issues

Related to Arvados - Bug #7008: [Workbench] Crashes with Fiddlesticks when trying to view a pipeline instance graph copied from another clusterNew2015-08-17

History

#1 Updated by Ward Vandewege over 2 years ago

  • Target version set to Bug Triage

#2 Updated by Radhika Chippada over 2 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#3 Updated by Brett Smith over 2 years ago

This is probably an effective duplicate of #7008. Workbench's log viewer code assumes it gets back a collection with something in it. If it stops doing that, it will handle all kinds of corner cases: no permissions, collection is gone, and more.

#4 Updated by Brett Smith about 2 years ago

Last comment seems misinformed. The job log record indicates that it wrote a real log with real contents. qr1hi just doesn't have a collection with that content address. It might've been modified after the fact? That'd be unusual, but definitely possible.

#5 Updated by Tom Clegg 9 months ago

  • Status changed from New to Closed

Also available in: Atom PDF