Feature #5944

[Workbench] Syntax highlighting for repository-browsing

Added by Tom Clegg about 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assigned To:
-
Category:
Workbench
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Something like this

sudo apt-get install python-pygments
pygmentize -O full,style=colorful -f html -o /tmp/keepclient.go.html sdk/go/keepclient/keepclient.go

...but preferably something that doesn't fork from passenger. Perhaps coderay, or do it client-side with https://github.com/ioquatix/jquery-syntax?


Related issues

Is duplicate of Arvados - Feature #5928: Syntax highlighting of viewing source in workbenchClosed05/06/2015

History

#1 Updated by Tom Clegg about 7 years ago

  • Description updated (diff)
  • Category set to Workbench

#2 Updated by Tom Clegg about 7 years ago

  • Status changed from New to Rejected
  • Target version deleted (Arvados Future Sprints)
  • Story points deleted (0.5)

Also available in: Atom PDF