Bug #5990

[SDKs] arv-run defaults to using arvados/jobs, without checking that it exists or is recent

Added by Brett Smith over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
SDKs
Target version:
Start date:
05/25/2015
Due date:
05/25/2015
% Done:

100%

Estimated time:
(Total: 1.00 h)
Story points:
0.5

Description

This can lead to pipeline failures that are mysterious to users, if arvados/jobs does not exist or has an SDK that's too old to run a current run-command.

Once #3454 is done and deployed, we may be able to rely on that, and take the default Docker image out of arv-run completely.


Subtasks

Task #6105: Review 5990-arv-run-default-runtimeResolvedPeter Amstutz

Task #6722: FixResolvedPeter Amstutz

Task #6734: Update docsResolvedPeter Amstutz


Related issues

Related to Arvados - Feature #3454: [API] Assign a system-default default docker image (instead of using the non-docker code path) if none is specified in runtime_constraints.Resolved05/07/2015

Follows (1 day) Arvados - Story #6096: [OPS] Implement a process to regularly deploy a Docker image for running jobs to Arvados clustersResolved05/22/2015

Associated revisions

Revision e69333d8
Added by Peter Amstutz over 4 years ago

Merge branch '5990-arv-run-default-runtime' closes #5990

History

#1 Updated by Brett Smith over 4 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#2 Updated by Brett Smith over 4 years ago

  • Target version changed from Arvados Future Sprints to 2015-06-10 sprint

#3 Updated by Brett Smith over 4 years ago

  • Story points set to 0.5

#4 Updated by Tom Clegg over 4 years ago

Perhaps the default image should have no Arvados SDK, and arv-run should use the version given in the API discovery document as arvados_sdk_version?

#5 Updated by Peter Amstutz over 4 years ago

  • Assigned To set to Peter Amstutz

#6 Updated by Brett Smith over 4 years ago

  • Assigned To deleted (Peter Amstutz)
  • Target version changed from 2015-06-10 sprint to 2015-07-08 sprint

#7 Updated by Brett Smith over 4 years ago

  • Assigned To set to Brett Smith

#8 Updated by Brett Smith over 4 years ago

  • Assigned To deleted (Brett Smith)
  • Target version changed from 2015-07-08 sprint to 2015-08-05 sprint

#9 Updated by Peter Amstutz over 4 years ago

  • Assigned To set to Peter Amstutz

#10 Updated by Nico César over 4 years ago

I see no unittest for this. Is because they are too hard to reproduce? I did a bunch of greps and I coulnd't find ant "arv run" excecutions on our testsuite

I see you updated doc/user/topics/arv-run.html.textile.liquid

but there is also

doc/sdk/cli/subcommands.html.textile.liquid
arvados/docker/build/doc/sdk/cli/subcommands.html.textile.liquid

that need change.

#11 Updated by Peter Amstutz over 4 years ago

  • Status changed from New to In Progress

#12 Updated by Peter Amstutz over 4 years ago

Nico Cesar wrote:

I see no unittest for this. Is because they are too hard to reproduce? I did a bunch of greps and I coulnd't find ant "arv run" excecutions on our testsuite

Unfortunately that's correct, there isn't any automated testing of job running in the test suite, which it pretty hard to have useful tests for tools like arv-run that submit jobs.

I see you updated doc/user/topics/arv-run.html.textile.liquid

but there is also

doc/sdk/cli/subcommands.html.textile.liquid

Fixed.

arvados/docker/build/doc/sdk/cli/subcommands.html.textile.liquid

That's copied from the above file.

#13 Updated by Nico César over 4 years ago

LGTM

#14 Updated by Peter Amstutz over 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 67 to 100

Applied in changeset arvados|commit:e69333d856baabf8bbbc27602850dcfe86309d23.

Also available in: Atom PDF