Bug #6943

[Git hosting] arvados-git-httpd should return 4xx, not 5xx, for authentication errors

Added by Tom Clegg almost 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
Git hosting
Target version:
-
Start date:
08/10/2015
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

Currently, as verified by tests, arvados-git-httpd returns 500 when the servers are all working perfectly but the client used an invalid token.

Existing test case:

func (s *IntegrationSuite) TestInvalidToken(c *check.C) {
    for _, repo := range []string{"active/foo.git", "active/foo/.git"} {
        err := s.runGit(c, "no-such-token-in-the-system", "fetch", repo)
        c.Assert(err, check.ErrorMatches, `.* 500 while accessing.*`)
    }
}

This response should have been 401, not 500.


Related issues

Is duplicate of Arvados - Bug #6780: [git] "git clone https://..." with a bogus token should respond 4xx, not 5xxNew07/28/2015

History

#1 Updated by Brett Smith almost 7 years ago

  • Status changed from New to Duplicate
  • Target version deleted (Arvados Future Sprints)

Duplicates #6780. I'll merge the descriptions.

#2 Updated by Brett Smith almost 7 years ago

  • Target version set to Arvados Future Sprints

#3 Updated by Brett Smith almost 7 years ago

  • Target version deleted (Arvados Future Sprints)

Also available in: Atom PDF