Bug #6998

[Docker] Workbench image doesn't serve HTTPS

Added by Brett Smith almost 2 years ago. Updated 4 months ago.

Status:ClosedStart date:08/17/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Docker
Target version:Arvados Future Sprints
Story points-
Velocity based estimate-

Description

Steps to reproduce:

$ docker pull arvados/workbench
$ docker run --name=workbenchbug arvados/workbench
$ curl --verbose -kLf "http://$(docker inspect workbenchbug | grep IPAddress | cut -d\" -f4)" 

The last command is analogous to what arvdock runs to detect when the cluster is ready. It doesn't work, because the response is a 301 to redirect the URL to HTTPS, but the Workbench Docker image has no configuration to serve HTTPS.

I think the simplest fix is to set force_ssl: false in the image's application.yml, but there may be other options.

Associated revisions

Revision d929be45
Added by Brett Smith almost 2 years ago

6998: Set force_ssl: false in Workbench Docker image.

This better matches the existing Docker image configuration, which
currently does not serve HTTPS at all. Refs #6998.

History

#1 Updated by Brett Smith almost 2 years ago

  • Subject changed from [Docker] Workbench image redirects to HTTPS, but doesn't serve HTTPS to [Docker] Workbench image doesn't serve HTTPS
  • Target version changed from 2015-09-02 sprint to Arvados Future Sprints

I pushed the simple fix, which makes this less pressing. I'll leave this ticket open if we want to consider more thorough solutions like having the image serve HTTPS.

#2 Updated by Tom Clegg 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF