Story #7928

[Keep] keepstore identifies underlying volumes to clients

Added by Brett Smith over 2 years ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
Keep
Target version:
-
Start date:
12/02/2015
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

The problem today: Keep clients figure if they write a block to a Keepstore, that created X-Keep-Replicas-Stored unique copies (default 1). This assumption is broken when multiple Keepstores share underlying storage (e.g., an object store).

Make it possible for clients to know how many copies of the block exist on disk.

  • PUT responses should list which volume(s) the block was stored on, and how many copies live on each.
  • Index responses should list which volume(s) each block lives on, and how many copies live on that volume.

Related issues

Is duplicate of Arvados - Feature #11644: [keepstore] mount-oriented APIsResolved2017-05-09

Blocks Arvados - Story #7929: [SDKs] PySDK KeepClient considers volume IDs when replicatingNew2015-12-02

Blocks Arvados - Story #7930: [SDKs] GoSDK KeepClient considers volume IDs when replicatingNew2015-12-02

Blocks Arvados - Story #7931: [keep-balance] Count block replication by volume IDsResolved2015-12-02

Blocks Arvados - Story #7932: [Keep] keepproxy aggregates and reports volume IDs from KeepstoresNew2015-12-02

History

#1 Updated by Brett Smith over 2 years ago

  • Tracker changed from Bug to Story

#2 Updated by Tom Clegg 12 months ago

  • Status changed from New to Duplicate

covered by #11644

Also available in: Atom PDF