Bug #7959

Default Replica Setting does'nt work

Added by Chen Chen over 3 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
Keep
Target version:
-
Start date:
12/08/2015
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

I set:
"-default-replicas=1" on keepproxy
"default_collection_replication: 1" on API
and still, arv-put and output from pipelines defaults to 2 copies.
(If I fill up one of the keep with trash files, it told me "want 2 wrote 1".)

BTW, uploading from workbench seems using the correct replica value.
(If I fill up one of the keep, arv-put --replication 1 works, upload on workbench also works)


Related issues

Is duplicate of Arvados - Story #7476: [SDKs] Ensure `arv keep put` replicates properlyNew10/07/2015

History

#1 Updated by Brett Smith over 3 years ago

Chen,

We made a change that we expected to address this somewhat recently, in #7254, pushed on 7 October. Can you please let me know what version of arv-put you saw this with, by running pip freeze | grep arvados-python on the same host as arv-put, and pasting the output here?

The last part of the version is a timestamp. The main thing I'm looking for is whether it's earlier or later than 2015-10-07. Thanks in advance.

#2 Updated by Brett Smith over 3 years ago

  • Status changed from New to Duplicate

Please disregard my previous note, I see your report is a little different and I understand the distinction now. We already have a story to make this change in #7476. I am closing this issue as a duplicate of that. Please feel free to follow along there.

Also available in: Atom PDF