[SDK] "gem install arvados" fails on ruby <2.2.2 since activesupport 5.0.0 came out
|Assignee:||Tom Clegg||% Done:|
|Velocity based estimate||-|
********** Running sdk/ruby install ********** WARNING: open-ended dependency on activesupport (>= 3.2.13) is not recommended if activesupport is semantically versioned, use: add_runtime_dependency 'activesupport', '~> 3.2', '>= 3.2.13' WARNING: See http://guides.rubygems.org/specification-reference/ for help Successfully built RubyGem Name: arvados Version: 0.1.20151207150126 File: arvados-0.1.20151207150126.gem ... Fetching: activesupport-5.0.0.beta1.gem (100%) ERROR: Error installing arvados-0.1.20151207150126.gem: activesupport requires Ruby version >= 2.2.2. ********** !!!!!! sdk/ruby install FAILED !!!!!! **********
#3 Updated by Tom Clegg over 1 year ago
This looks like a bug in gem: it selects a version of the activesupport gem that it isn't capable of installing.
proposed workaround: introduce an artificial constraint activesupport < 5.0.0 to our gem, so that it can be installed on ruby < 2.2.2 without hitting this bug.