Bug #9487

Subprojects of public projects should not be on the public projects page

Added by Bryan Cosca about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
06/23/2016
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

For example: https://cloud.curoverse.com/projects/qr1hi-j7d0g-nj79lednpor7s32

Is on https://cloud.curoverse.com/projects/public. I'm guessing because permission is inherited from the parent project https://cloud.curoverse.com/groups/qr1hi-j7d0g-662ij1pcw6bj8uj which is explicitly shared with Anonymous users.

My idea is that only projects that are explicitly shared with anonymous users should be on the public page.


Related issues

Is duplicate of Arvados - Story #6307: [Workbench] Public project listing should exclude subprojectsNew

History

#1 Updated by Brett Smith about 4 years ago

  • Status changed from New to Duplicate

Duplicates #6307.

Also available in: Atom PDF