Project

General

Profile

Actions

Bug #9624

closed

[Crunch2] c-d-slurm writes an array of bytes instead of the sbatch error message

Added by Brett Smith about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Crunch
Target version:
Story points:
0.5

Description

crunch-dispatch-slurm wrote this in the logs:

2016-07-18_16:37:18.48914 2016/07/18 16:37:18 Error submitting container 9tee4-dz642-kubmww2by6g43kr to slurm: Container submission failed [sbatch --share --job-name=9tee4-dz642-kubmww2by6g43kr --mem-per-cpu=1 --cpus-per-task=1 --priority=1]: exit status 1 [115 98 97 116 99 104 58 32 117 110 114 101 99 111 103 110 105 122 101 100 32 111 112 116 105 111 110 32 39 45 45 112 114 105 111 114 105 116 121 61 49 39 10 84 114 121 32 34 115 98 97 116 99 104 32 45 45 104 101 108 112 34 32 102 111 114 32 109 111 114 101 32 105 110 102 111 114 109 97 116 105 111 110 10]

These are ASCII or UTF-8 bytes, written as integers:

>>> ints = [int(x) for x in "115 98 97 116 99 104 58 32 117 110 114 101 99 111 103 110 105 122 101 100 32 111 112 116 105 111 110 32 39 45 45 112 114 105 111 114 105 116 121 61 49 39 10 84 114 121 32 34 115 98 97 116 99 104 32 45 45 104 101 108 112 34 32 102 111 114 32 109 111 114 101 32 105 110 102 111 114 109 97 116 105 111 110 10".split()]
>>> print(''.join(chr(n) for n in ints))
sbatch: unrecognized option '--priority=1'
Try "sbatch --help" for more information

The problem is this line in crunch-dispatch-slurm.go:

log.Printf("Error submitting container %s to slurm: %v",
    container.UUID, err)

Apparently %v is the wrong format for err's type.

Actions #1

Updated by Brett Smith about 8 years ago

  • Tracker changed from Idea to Bug
Actions #2

Updated by Brett Smith about 8 years ago

  • Target version set to Arvados Future Sprints
Actions #3

Updated by Brett Smith about 8 years ago

  • Story points set to 0.5
Actions #5

Updated by Tom Clegg about 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:5b1176df5257cd16350fb4da5a6d6157c58a0a0f.

Actions #6

Updated by Brett Smith about 8 years ago

  • Status changed from Resolved to New
  • Assigned To set to Tom Clegg
  • Target version changed from Arvados Future Sprints to 2016-07-20 sprint
  • % Done changed from 100 to 0
Actions #7

Updated by Tom Clegg about 8 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF