Story #9677

[Docs] Install guide needs to create arvados/jobs:latest Docker image as a standard object

Added by Brett Smith about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Documentation
Target version:
Start date:
07/29/2016
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Description

This Docker image is required by arvados-cwl-runner

Add the command

arv-keepdocker arvados/jobs latest

on the standard objects page

http://doc.arvados.org/install/create-standard-objects.html

Subtasks

Task #9729: review 9677-update-install-docsResolvedWard Vandewege


Related issues

Related to Arvados - Bug #9659: [CWL] Jobs crash when arvados/jobs:latest is not suitable to run CWL jobsNew

Related to Arvados - Support #9685: [arvbox] Docker image locator not found for arvados/jobsResolved08/02/2016

Associated revisions

Revision debcd25f (diff)
Added by Ward Vandewege about 4 years ago

Document how to download and tag the arvados/jobs Docker image.

refs #9677

Revision 3c101af9 (diff)
Added by Ward Vandewege about 4 years ago

Document how to download and tag the arvados/jobs Docker image.

refs #9677

Revision 6add4471
Added by Ward Vandewege about 4 years ago

Merge branch '9677-update-install-docs'

closes #9677

History

#1 Updated by Ward Vandewege about 4 years ago

  • Description updated (diff)

#2 Updated by Ward Vandewege about 4 years ago

  • Description updated (diff)
  • Assigned To set to Ward Vandewege
  • Story points set to 0.5

#3 Updated by Brett Smith about 4 years ago

Adding the --pull switch would help ensure that you're actually installing the latest version, just in case the local Docker daemon has an older version already. It's a judgment call, though, as to whether it's "required."

#4 Updated by Ward Vandewege about 4 years ago

  • Target version set to 2016-08-17 sprint

#5 Updated by Tom Clegg about 4 years ago

I think we should add the --pull flag as Brett suggested. That way the text "The following command downloads the latest arvados/jobs image from Docker Hub" will be true.

With that change, 9677-update-install-docs LGTM.

#6 Updated by Ward Vandewege about 4 years ago

  • Status changed from New to Resolved

Tom Clegg wrote:

I think we should add the --pull flag as Brett suggested. That way the text "The following command downloads the latest arvados/jobs image from Docker Hub" will be true.

With that change, 9677-update-install-docs LGTM.

Great, done and merged.

Also available in: Atom PDF