Project

General

Profile

Actions

Idea #9760

closed

Remove intermediary checksum from Keep store and use cut through block forwarding

Added by Tom Morris over 7 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Normal
Assigned To:
-
Category:
Keep
Target version:
-
Story points:
-

Related issues

Related to Arvados - Feature #2960: Keepstore can stream GET and PUT requests using keep-gateway APIIn ProgressTom Clegg02/16/2024Actions
Actions #1

Updated by Tom Clegg about 5 years ago

  • Status changed from New to Rejected

The pipelining part of this is a duplicate of #2960.

We don't want to remove the checksum.
  • Although Keep does not yet automatically repair corrupt data, or even report it anywhere other than keepstore logs, keepstore is the right place to detect it.
  • Hashing is fast: with pipelining, performance impact is negligible, perhaps undetectable.
Actions

Also available in: Atom PDF