Bug #9769

[CWL] When a CWL job is executed in crunch1, the pipeline instance created never completes even after all required jobs are completed

Added by Radhika Chippada over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

https://workbench.9tee4.arvadosapi.com/pipeline_instances/9tee4-d1hrv-1p44pmqmp5yrp97

Run using command: arvados-cwl-runner bwa-mem.cwl bwa-mem-input.yml in arvados/doc/user/cwl/bwa-mem directory.

History

#1 Updated by Radhika Chippada over 4 years ago

  • Subject changed from [CWL] When a cwl job is executed in crunch1, the pipeline instace created never completes. to [CWL] When a cwl job is executed in crunch1, the pipeline instace created never completes even after all the required jobs are completed.
  • Description updated (diff)

#2 Updated by Tom Morris over 4 years ago

  • Subject changed from [CWL] When a cwl job is executed in crunch1, the pipeline instace created never completes even after all the required jobs are completed. to [CWL] When a CWL job is executed in crunch1, the pipeline instance created never completes even after all required jobs are completed

This pipeline is showing as completed successfully now.

Radhika - can you check to see if you think that it was a transient issue or something that needs to be investigated?

#3 Updated by Radhika Chippada over 4 years ago

  • Status changed from New to Resolved

This is no longer failing with the latest arvados CWL runner.

Go to https://workbench.9tee4.arvadosapi.com/pipeline_instances and type bwa-mem.cwl in the search box above "Compare 2 or 3 selected" and you will see that the jobs that were run this morning were marked properly as completed.

#4 Updated by Radhika Chippada over 4 years ago

  • Target version set to 2016-08-17 sprint

Also available in: Atom PDF