Support #16861

Updated by Peter Amstutz about 1 year ago

Is the minimum version of Ruby we support in Arvados 2.1 going to be ruby 2.3 or ruby 2.5?

Our package build and test pipeline uses Ruby 2.5 from rvm. The last component that was testing with Ruby 2.3 was arvbox, but that's being moved to ruby 2.5. We can only support Ruby 2.3 if there's something in the jenkins pipeline that checks that it actually works.

Debian 10 and Ubuntu 18.04 have Ruby 2.5, so we can continue to recommend installing from packages.

Debian 9 and Ubuntu 16.04 have 2.3. If we require 2.5, the docs need to direct people to use rvm.


Back