Bug #18309

Updated by Ward Vandewege 3 months ago

On ruby 2.5:

<pre>
# ruby -v
ruby 2.5.5p157 (2019-03-15 revision 67260) [x86_64-linux-gnu]
</pre>

<pre>
# /usr/local/bin/arvados-login-sync -h
Traceback (most recent call last):
7: from /usr/local/bin/arvados-login-sync:23:in `<main>'
6: from /usr/lib/ruby/2.5.0/rubygems.rb:304:in `activate_bin_path'
5: from /usr/lib/ruby/2.5.0/rubygems.rb:304:in `synchronize'
4: from /usr/lib/ruby/2.5.0/rubygems.rb:305:in `block in activate_bin_path'
3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1440:in `activate'
2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1458:in `activate_dependencies'
1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1458:in `each'
/usr/lib/ruby/2.5.0/rubygems/specification.rb:1466:in `block in activate_dependencies': can't satisfy 'faraday (< 0.16)', already activated 'faraday-0.17.4' (Gem::LoadError)
</pre>

<pre>
# gem list |grep arv
arvados (2.3.0)
arvados-cli (2.3.0)
arvados-google-api-client (0.8.7.4)
arvados-login-sync (2.3.0)
</pre>

<pre>
gem list |grep faraday
faraday (0.17.4, 0.15.4)
</pre>

<pre>
gem uninstall faraday -v 0.15.4

You have requested to uninstall the gem:
faraday-0.15.4

arvados-login-sync-2.3.0 depends on faraday (< 0.16)
If you remove this gem, these dependencies will not be met.
Continue with Uninstall? [yN] n
</pre>

<pre>
# gem uninstall faraday -v0.17.4

You have requested to uninstall the gem:
faraday-0.17.4

arvados-2.3.0 depends on faraday (>= 0.17.4)
If you remove this gem, these dependencies will not be met.
Continue with Uninstall? [yN] n
</pre>

Back