Task #6242

Feature #6187: [Crunch] Flag to disable job reuse with GATK Queue plugin

Test to make sure it works

Added by Peter Amstutz over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
06/04/2015
Due date:
% Done:

0%

Estimated time:

History

#1 Updated by Peter Amstutz over 4 years ago

  • Status changed from New to In Progress
  • Start date set to 06/04/2015

#2 Updated by Bryan Cosca over 4 years ago

Testing with a small sample and a scatter of 3 here: qr1hi-d1hrv-z6afo1m08lhjfrc. Once this completes then I'll run again and see if it re-runs.

#3 Updated by Bryan Cosca over 4 years ago

Did not work: See qr1hi-d1hrv-nwdcxnawf854k2b and try hitting re-run with latest. I'm guessing this is now because arvados sees that everything didn't change so it actually doesn't re-run. Maybe we still need that magic parameter that counts up in the pipeline template to make it work.

Adding that parameter, running and then re-running to see if that changes anything.

See here: qr1hi-d1hrv-vilqlsxko3em3js

#4 Updated by Bryan Cosca over 4 years ago

So that made it actually run, I tried with my magic parameter of 1 : qr1hi-d1hrv-vilqlsxko3em3js and a magic parameter of 2 : qr1hi-d1hrv-93taci44e07qlh1 and it ran both times

#5 Updated by Bryan Cosca over 4 years ago

  • Status changed from In Progress to Closed
  • Remaining (hours) set to 0.0

Based on feedback from lunch yesterday, this is working as intended.

Also available in: Atom PDF