Story #14411

[API] Migrate api server config to use arvados/config.yml

Added by Peter Amstutz about 2 months ago. Updated 4 days ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

We currently have two sources of truth for certain configuration options: arvados/config.yml (used by controller) and application.yml (used by Rails API server).

Propose adding an initializer to the Rails API server which reads configuration values from arvados/config.yml and sets the corresponding configuration parameters.


Related issues

Is duplicate of Arvados - Feature #13646: [API] Rails API server uses cluster configuration fileNew

History

#1 Updated by Peter Amstutz about 2 months ago

  • Tracker changed from Bug to Story

#2 Updated by Peter Amstutz about 2 months ago

  • Subject changed from [API] Migrate api server config to arvados.conf to [API] Migrate api server config to use arvados.conf
  • Description updated (diff)

#3 Updated by Peter Amstutz about 2 months ago

  • Subject changed from [API] Migrate api server config to use arvados.conf to [API] Migrate api server config to use arvados/config.yml
  • Description updated (diff)

#4 Updated by Tom Clegg 25 days ago

  • Is duplicate of Feature #13646: [API] Rails API server uses cluster configuration file added

#5 Updated by Tom Clegg 25 days ago

  • Status changed from New to Duplicate

#6 Updated by Tom Morris 4 days ago

  • Target version deleted (To Be Groomed)

Also available in: Atom PDF