Bug #3363

[Docker] quick fix for SSO - google openid has been deprecated, default to using Curoverse SSO server

Added by Ward Vandewege almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Associated revisions

Revision 4aea5131 (diff)
Added by Ward Vandewege almost 6 years ago

Be less presumptuous about the GNU/Linux distribution we are being run
on, and do not try to install ruby >= 1.9.3 automatically.

refs #3363

Revision 3862ce78 (diff)
Added by Ward Vandewege almost 6 years ago

  • Default to using the auth.curoverse.com SSO server. Add instructions
    in config.yml.example for using a local SSO server.
  • Do not prepopulate the config.yml file generated by build.sh with
    random values for _PW and _SECRET variables, let config.rb deal with
    that at build time.
  • Make config.rb a bit more robust in choosing those values for _PW and
    _SECRET by not depending on any particular key order in the config Hash.

refs #3363

Revision f43267ad (diff)
Added by Ward Vandewege almost 6 years ago

Update Docker install documentation:

  • suggest use of build.sh to generate config.yml
  • reflect now default use of Curoverse SSO server

refs #3363

Revision 72994909 (diff)
Added by Ward Vandewege almost 6 years ago

Only the deepclean Make action should remove the skydns-image and skydock-image files.

refs #3363

Revision 1e66f628 (diff)
Added by Ward Vandewege almost 6 years ago

Provide a bit more detail about build.sh in the documentation.

refs #3363

Revision 80b502ea
Added by Ward Vandewege almost 6 years ago

Merge branch '3363-docker-add-option-to-use-auth.curoverse.com'

refs #3363

History

#1 Updated by Ward Vandewege almost 6 years ago

  • Assigned To set to Ward Vandewege

#2 Updated by Ward Vandewege almost 6 years ago

  • Story points set to 1.0

#3 Updated by Ward Vandewege almost 6 years ago

  • Subject changed from [Docker] fix SSO - google openid has been deprecated to [Docker] quick fix for SSO - google openid has been deprecated, default to using Curoverse SSO server

#4 Updated by Ward Vandewege almost 6 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF