Bug #5521

[Workbench] Slow download speed from browser

Added by Bryan Cosca over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Workbench
Target version:
-
Start date:
03/20/2015
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

From a customer: "We tried downloading both output files and noticed two things: 1: While the speed when uploading is around 10MB/s, downloading goes at roughly 300kb/s. 2: Due to the download rate the download stops when done through the browser."


Related issues

Related to Arvados - Story #5824: [Workbench] [Keep] collection browse/download serverResolved05/21/2015

History

#1 Updated by Brett Smith over 6 years ago

  • Subject changed from Slow download speed from browser to [Workbench] Slow download speed from browser
  • Category set to Workbench
  • Target version set to Bug Triage

I think this might be related to the 1GiB limit bug that was resolved last sprint, but need to investigate.

#2 Updated by Peter Amstutz over 6 years ago

The second one (download stops) could plausibly be the 1 GiB limit bug. The first one has been observed but not investigated, but seems likely to be an issue with out AWS configuration, but we should do some benchmarking of AWS vs GCP vs on-premise to get a handle on it.

#4 Updated by Tom Clegg over 6 years ago

  • Status changed from New to In Progress

#5 Updated by Ward Vandewege over 6 years ago

Bryan - this ticket requires more information: which file, exactly, were they trying to download?

Now that qr1hi lives on GCP, I can't reproduce slowness - currenlty downloading a fastq at over 5 MiB/second.

Thanks,
Ward.

#6 Updated by Brett Smith over 6 years ago

  • Status changed from In Progress to Closed
  • Target version deleted (Bug Triage)

I'm closing this for sort of a combination of reasons. One, we already know that general Workbench download performance is not where we want it to be, and we already have tickets to address that generally. #5824 is the best example.

Two, information to determine if there's a specific download that is causing trouble is not available.

Also available in: Atom PDF