Bug #3698

[Crunch] Pipeline runner should detect when "output_of" refers to a non-existent component, and fail instead of staying in RunningOnServer state forever.

Added by Peter Amstutz over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Crunch
Target version:
Start date:
10/17/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Subtasks

Task #4715: Retest on qr1hi after deployResolved

Task #4608: Investigate regressionResolvedPeter Amstutz

Task #4257: Review 3698-invalid-output-ofResolvedPeter Amstutz

Task #4145: Add validation that output_of links refer to existing componentsResolvedPeter Amstutz


Related issues

Has duplicate Arvados - Bug #4200: [Crunch] Notify user, cancel pipeline when it cannot run because a parameter is the output_of a nonexistent componentClosed10/15/2014

Has duplicate Arvados - Task #4171: [Crunch] arv-run-pipeline-instance should detect bad "output_of" values and fail the pipelineClosed10/09/2014

Has duplicate Arvados - Bug #4064: [Crunch] Typoed "output_of" value in pipeline leaves a job stuck in the queueResolved10/09/2014

Associated revisions

Revision 269adb30
Added by Peter Amstutz about 6 years ago

Merge branch '3698-invalid-output-of' closes #3698

Revision 543d39ea (diff)
Added by Peter Amstutz almost 6 years ago

Update version pin of arvados-cli gem. refs #3698

History

#1 Updated by Peter Amstutz over 6 years ago

  • Subject changed from Pipeline runner doesn't detect when "output_of" refers to non-existent component, will stall instead of failing. to [Crunch] Pipeline runner doesn't detect when "output_of" refers to non-existent component, will stall instead of failing.
  • Category set to Crunch

#2 Updated by Peter Amstutz about 6 years ago

  • Target version set to Arvados Future Sprints

#3 Updated by Tom Clegg about 6 years ago

  • Subject changed from [Crunch] Pipeline runner doesn't detect when "output_of" refers to non-existent component, will stall instead of failing. to [Crunch] Pipeline runner should detect when "output_of" refers to a non-existent component, and fail instead of staying in RunningOnServer state forever.
  • Story points set to 0.5

#4 Updated by Ward Vandewege about 6 years ago

  • Target version changed from Arvados Future Sprints to 2014-10-29 sprint

#5 Updated by Peter Amstutz about 6 years ago

  • Assigned To set to Peter Amstutz

#6 Updated by Peter Amstutz about 6 years ago

  • Status changed from New to In Progress

#7 Updated by Brett Smith about 6 years ago

5716ec8 is good to merge, thanks.

#8 Updated by Anonymous about 6 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:269adb302bf244332706a1fe053feddc402eb4be.

#9 Updated by Brett Smith about 6 years ago

  • Status changed from Resolved to New
  • Target version changed from 2014-10-29 sprint to Bug Triage

This needs another look. This logic should've detected qr1hi-d1hrv-i1d1jffl9nd5ylv, but apparently didn't—right now the pipeline is active and there's nothing in the log.

#10 Updated by Ward Vandewege about 6 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#11 Updated by Tom Clegg about 6 years ago

  • Target version changed from Arvados Future Sprints to 2014-12-10 sprint

#12 Updated by Peter Amstutz almost 6 years ago

API's Gemfile.lock arvados-cli (0.1.20141014201516) version pin predates the fix by three days, so the reason the problem appeared is that the api server is still using the old version of arv-run-pipeline-instance.

#13 Updated by Tom Clegg almost 6 years ago

  • Status changed from New to Feedback

#14 Updated by Peter Amstutz almost 6 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF